WP Super Cache提示找不到apache模块的解决方法

相信很多朋友都用过WP Super Cache这款wordpress的缓存插件,这款插件的缓存效果非常好,我在之前的文章使用WP Super Cache插件加速博客中也对其进行过介绍。
tennfy采用debian中lamp一键安装脚本在vps中安装apache之后,在Wordpress中遇到了WP Super Cache提示找不到apache模块的问题。不过网上已经有朋友给出了相应的解决办法,也希望能够分享给同样遇到该问题的朋友。

问题表现

打开Wordpress中WP Super Cache管理页面,会提示以下信息:

missing-apache

可以看到,提示信息说明apache缺少mod_headers以及mod_expires两个模块。

解决方法

事实上在/etc/apache2/mods-available目录下我们可以看到apache提供的所有模块,在这里我们能够找到mod_headers以及mod_expires两个模块。但是在控制模块生效的/etc/apache2/mods-enabled/目录下却没有发现这两个模块。因此,解决这个的方法非常简单,就是从mods-available目录向mods-enabled目录做这两个模块的软连接即可。

代码如下:

1
2
3
ln -s /etc/apache2/mods-available/expires.load /etc/apache2/mods-enabled/
 
ln -s /etc/apache2/mods-available/headers.load /etc/apache2/mods-enabled/

然后重启apache

1
/etc/init.d/apache2 restart

重启之后,警告提示消失,说明有效解决问题。

参考文章:wp super cache提示找不到apache模块的解决方法

此条目发表在服务器分类目录,贴了标签。将固定链接加入收藏夹。